Issues with email deliverability
Incident Report for Afterthought System
Resolved
This incident has been resolved.
Posted Jan 05, 2022 - 21:46 EST
Identified
We are aware that no emails under the afterthought-system.com domain are able to receive emails. We are working to resolve this issue.

If you're trying to reach our support team, please use the live chat function at https://terminal.afterthought-system.com.
Posted Jan 05, 2022 - 21:31 EST