Postmark is experiencing a delay in deliverability to select providers
Incident Report for Afterthought System
Resolved
Sending times are back to normal. Thanks for your patience!
Posted Feb 21, 2022 - 21:34 EST
Investigating
Mail delivery to Gmail, Hotmail, Yahoo, and AOL is currently delayed by a few minutes. The Postmark Team is investigating.
Posted Feb 21, 2022 - 18:02 EST
This incident affected: Postmark.