afterthought-system.com is experiencing technical issues
Incident Report for Afterthought System
Resolved
We have moved over to another hosting provider for our root domain in lieu. Our root site may be down for maintenance for a day.
Posted Dec 12, 2021 - 02:34 EST
Monitoring
We are aware of an issue with afterthought-system.com. We have identified the issue as a billing issue and have reached out to our host, Bubble to resolve it.
Posted Dec 05, 2021 - 19:21 EST
This incident affected: Afterthought System Home.